Exchange 2013 CU9 langsam im online Modus

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Exchange 2013 CU9 langsam im online Modus

    Hallo,

    ich habe eine Exchange 2003 mit Zwischenschritt über Exchange 2010 auf 2013 erfolgreich migriert inklusive 6GB öffentliche Ordner.
    Das einzige was mir nun Sorgen macht ist das alle Postfächer sehr träge sind im Outlook sofern diese im Online Modus betrieben werden.
    Wenn der Cache Modus an ist läuft es natürlich flüssiger aber da alle Benutzer auf einen Windows Terminal Server 2008R2 arbeiten, möchte ich ungern den Cache Modus aktiviert lassen.
    Mit dem Exchange 2003 und 2010 war dies auch möglich und die Benutzer haben sich nicht im Online Modus über die Performance beklagt.
    Ich kann mir auch nicht vorstellen das der Exchange 2013 so dermaßen langsamer arbeiten soll.

    Fakten zu den Servern:
    Exchange 2013
    - auf ESXi 5.5 U2 HP Custom Image
    - VMXNET3 als vNIC
    - 16GB vRAM zugewiesen
    - 4 vCPUs ( Xeon E5-2630@2,6Ghz) zugewiesen
    - 2 x virtuelle Festplatten C: als Systempartition mit 65GB (belegt 49GB und E: als Exchange Partition mit 80 GB (32GB belegt) worauf die Exchange Datenbank und die Logs liegen
    Die LUN für den Exchange und Terminalserver liegt jeweils auf einem HP Storage mit 15K Platten und einem Raid6 Verbund
    - Datenbankgröße: 27GB
    - Postfächer 35
    Serverbetriebssystem Windows 2012R2 Standard
    Exchange CU9 Installation mit allen Windows Updates
    CPU Auslastung im Durchschnitt bei 10-15%
    RAM Auslastung 11GB von 16GB im Durchschnitt 68%

    Terminal Server:
    auf ESXi 5.5 U2 HP Custom Image
    - VMXNET3 als vNIC
    - 24GB vRAM zugewiesen
    - 4 vCPUs ( Xeon E5-2630@2,6Ghz) zugewiesen
    - 1 virtuelle Festplatte mit 250 GB (214GB belegt)
    - 16 aktive User
    - Outlook 2010
    - Windows 2008R2 mit RD Sitzungshost
    CPU Auslastung 20-30% im Durchschnitt
    Ram Auslastung 16GB von 24GB


    Als Domänencontroller habe ich momentan noch einen SBS2003. Als zweiten DC habe ich schon meinen neuen 2012R2 in die Domäne.
    Als nächsten Schritt wollte ich eigentlich die FSMO Rollen auf den 2012R2 übertragen und den 2003er runterstufen. Aber das Performance Problem war mir erstmal wichtiger und wurmt mich ziemlich.

    Das Kuriose ist das ich das selbe Problem bei einem anderen Projekt habe, Da habe ich auch alles vom SBS2003 gesplittet auf einen 2012R2 DC und 2012R2 mit Exchange 2013 migriert und dort auch schon den alten 2003DC komplett herausgenommen.
    Dort arbeiten die User allerdings mit Workstations und nicht auf einem Terminal Server aber ohne aktivierten Cache Modus ist das Outlook 2010 auch super langsam. Dort hat es mich bloß nicht gestört weil die User halt nicht auf einem Terminal Server arbeiten.
    Die Server sind dort ebenfalls virtualisiert auf einem ESXi 6.0

    Ich hoffe mir kann jemand helfen. Bei Google wurde ich leider nicht wirklich fündig.

    Beste Grüße
  • Moin Robert,

    Danke für deine Antwort.
    Chimney war bereits deaktiviert weil es wohl bei Server2012R2 standardmäßig deaktiviert ist wie es auch dort steht.
    Ich habe nun noch rss deaktiviert und prüfe die nächsten Tage ob es das Problem löst und berichte dann darüber.

    Ich bin mir nicht sicher ob das evtl. doch irgendwas mit dem Offload zu tun hat in den Netzwerkkarten Einstellungen.
    Darüber habe ich auch ein paar Artikel gefunden aber leider verrät dort niemand welche Offload Einstellungen man deaktivieren soll weil es dort mehrere gibt.

    Beste Grüße aus HH.
  • Danke für die Info, mache ich in der Zukunft!


    Leider war es aber nicht die Lösung!

    Ich werde nun erstmal CU10 installieren. In den Release Notes habe ich aber nichts gefunden was mein Problem beheben könnte.
    Es wäre auch mal interessant ob andere dieses Problem haben.
    Ich konnte bei Google nur herausfinden das man bei der VMXNET3 Netzwerkkarte die Offload Optionen deaktivieren soll in den Treiber Einstellungen.
    Dort gibts aber bestimmt 8 Optionen mit Offload und ich denke nicht das man das alles ausschalten sollte. ipv4 offload Deaktivierung brachte jedenfalls auch keinen Performance Zuwachs.

    Ich melde mich nach der CU10 Installation.
  • gelöst:

    Also ich habe das CU10 installiert, jedoch hat dies performance Technisch nichts gebracht!

    Aber ich habe die Lösung im Internet doch noch gefunden!
    Folgende Einträge in der Registry sind nötig und zwar Clientseitig bzw, auf alle Windows 7 / Windows 2008R2 TS Server worauf Outlook 2010 installiert ist:
    1.Start Registry Editor (Regedit.exe).
    2.Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces
    the interfaces will be listed underneath by automatically generated GUIDs like {064A622F-850B-4C97-96B3-0F0E99162E56}
    3.Click each of the interface GUIDs and perform the following steps:
    a. On the Edit menu, point to New, and then click DWORD value.
    b. Name the new value TcpAckFrequency, and assign it a value of 1.
    4.Exit the Registry Editor.
    5.Restart Windows for this change to take effect


    Seitdem ich den Reg Eintrag auf das Interface gesetzt habe ist Outlook rasend schnell, auch im Online Modus!
    So habe ich es mir vorgestellt!
    Bei meinem 2. Kunden auf dem Terminal Server habe ich das ebenfalls durchgeführt und selber Effekt, Outlook ist nun auch da rattig schnell, auch in den öffentlichen Ordnern!

    Dieses Problem tritt wohl nach einer Exchange 2013 Migration auf in Verbindung wenn Outlook auf Windows 7 Maschinen / Windows 2008R2 Terminalserver eingesetzt wird.

    Quellen:
    community.spiceworks.com/topic…igrating-to-exchange-2013
    social.technet.microsoft.com/F…?forum=exchangesvrclients

    Beste Grüße M.Nitsche