Problem bei Installation von Exchange 2010 SP2

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Problem bei Installation von Exchange 2010 SP2

    Hallo Kollegen,

    ich habe bei einem Bekannten ein Problem bei der Installation des SP2 für Exchange 2010 auf einen SBS 2011. Die Version des installierten Exchange ist 14.1 Build 218.15. Zusätzlich ist noch die Trend Micro Worry Free Advanced Suite installiert.
    (Nachtrag: Installation vom SP3 verursacht selben Fehler)

    Die Installation bleibt bei diesem Fehler stehen:

    Quellcode

    1. Fehler:
    2. Der folgende Fehler wurde generiert, als "$error.Clear();
    3. Write-ExchangeSetupLog -Info "Set the default Accepted domain from the default recipient policy";
    4. $defaultEmailAddressPolicy = get-EmailAddressPolicy -Identity:"Default Policy";
    5. $defaultSmtpTemplate = $defaultEmailAddressPolicy.EnabledPrimarySMTPAddressTemplate;
    6. $index = $defaultSmtpTemplate.IndexOf("@") + 1;
    7. $eapAuthoritativeDomain = $defaultSmtpTemplate.Substring($index);
    8. $acceptedDomains = Get-AcceptedDomain;
    9. $defaultDomain = $acceptedDomains | Where {$_.DomainName -eq $eapAuthoritativeDomain -or $_.DomanName -eq "*.$eapAuthoritativeDomain" };
    10. # If an accepted domain couldn't be found which matches the default email address policy, then try and find
    11. # the wildcard domain which matches it and set that as the default
    12. While ($defaultDomain -eq $null -and $eapAuthoritativeDomain.Contains(".")) {
    13. $index = $eapAuthoritativeDomain.IndexOf(".") + 1;
    14. $eapAuthoritativeDomain = $eapAuthoritativeDomain.Substring($index);
    15. $defaultDomain = $acceptedDomains | Where {$_.DomainName -eq "*.$eapAuthoritativeDomain" };
    16. };
    17. $defaultDomain | set-accepteddomain -MakeDefault:$true;
    18. Write-ExchangeSetupLog -Info "Default domain $defaultDomain";
    19. " ausgeführt wurde: "Das Argument kann nicht an den Parameter "Identity" gebunden werden, da es NULL ist.".
    20. Das Argument kann nicht an den Parameter "Identity" gebunden werden, da es NULL ist.
    Alles anzeigen
    Habt ihr spontan eine Idee was hier das Problem sein könnte ?

    Beste Grüße

    Flo
  • Hi Robert,

    ich habe mal ein Screenshot der Richtlinien angehängt. So sieht es bei dem Bekannten aus.

    Habe es mal mit der Richtlinie auf meinem Exchange verglichen. Bei mir Fehlen fehlen die Prefixe und die zweite Domain. Das dürfte aber doch keine Probleme machen.
    Bilder
    • addr_richtlinien.png

      35,42 kB, 631×262, 84 mal angesehen
  • Grade mal geschaut.

    Quellcode

    1. [PS] C:\Windows\system32>get-globaladdresslist -Identity "Globale Standardadressliste" | format-list
    2. RunspaceId : 9633d550-c345-4e88-9ea3-c04f3413d961
    3. IsDefaultGlobalAddressList : True
    4. Name : Globale Standardadressliste
    5. RecipientFilter : ((Alias -ne $null) -and (((ObjectClass -eq 'user') -or (ObjectClass -eq 'contact') -or (
    6. ObjectClass -eq 'msExchSystemMailbox') -or (ObjectClass -eq 'msExchDynamicDistributionLi
    7. st') -or (ObjectClass -eq 'group') -or (ObjectClass -eq 'publicFolder'))))
    8. LdapRecipientFilter : (&(mailNickname=*)(|(objectClass=user)(objectClass=contact)(objectClass=msExchSystemMail
    9. box)(objectClass=msExchDynamicDistributionList)(objectClass=group)(objectClass=publicFol
    10. der)))
    11. LastUpdatedRecipientFilter :
    12. RecipientFilterApplied : True
    13. IncludedRecipients :
    14. ConditionalDepartment : {}
    15. ConditionalCompany : {}
    16. ConditionalStateOrProvince : {}
    17. ConditionalCustomAttribute1 : {}
    18. ConditionalCustomAttribute2 : {}
    19. ConditionalCustomAttribute3 : {}
    20. ConditionalCustomAttribute4 : {}
    21. ConditionalCustomAttribute5 : {}
    22. ConditionalCustomAttribute6 : {}
    23. ConditionalCustomAttribute7 : {}
    24. ConditionalCustomAttribute8 : {}
    25. ConditionalCustomAttribute9 : {}
    26. ConditionalCustomAttribute10 : {}
    27. ConditionalCustomAttribute11 : {}
    28. ConditionalCustomAttribute12 : {}
    29. ConditionalCustomAttribute13 : {}
    30. ConditionalCustomAttribute14 : {}
    31. ConditionalCustomAttribute15 : {}
    32. RecipientContainer :
    33. RecipientFilterType : Custom
    34. IsValid : True
    35. ExchangeVersion : 0.1 (8.0.535.0)
    36. DistinguishedName : CN=Globale Standardadressliste,CN=All Global Address Lists,CN=Address Lists Container,CN
    37. =First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=contoso,D
    38. C=local
    39. Identity : \Globale Standardadressliste
    40. Guid : 92531c67-b345-4a6a-a1f7-981a44120fff
    41. ObjectCategory : contoso.local/Configuration/Schema/Address-Book-Container
    42. ObjectClass : {top, addressBookContainer}
    43. WhenChanged : 15.06.2012 12:12:49
    44. WhenCreated : 15.06.2012 12:12:49
    45. WhenChangedUTC : 15.06.2012 10:12:49
    46. WhenCreatedUTC : 15.06.2012 10:12:49
    47. OrganizationId :
    48. OriginatingServer : server.contoso.local
    Alles anzeigen
    Sieht soweit gut aus. Die Filter stimmen mit denen aus dem TechNet überein. Die Adressliste ist Default.

    Habt ihr noch eine Idee ?

    Kann ich die GAL einfach entfernen und neuanlegen? Oder gibt das später Probleme, wegen Referenzen und so weiter?

    Grüße

    Flo