Keine Verbindung mit Exchange Server / Testing the address book "Check Name" operation for user xx@xx.com against server mail.xx.com.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Keine Verbindung mit Exchange Server / Testing the address book "Check Name" operation for user xx@xx.com against server mail.xx.com.

    Ein Hallo an alle Exchange Experten!
    Ich habe aktuell einen Exchange 2016 (CU5) auf einen Windows Server 2012R2 am Laufen, also fast.
    Die web Anmeldungen über OWA, ECP etc. laufen alle einwandfrei. Autodiscover läuft auch OK (getestet mit Outlook und testconnectivity.microsoft.com)
    Nur leider habe ich Probleme mit den „Exchange Adressbuch“ wie es mir scheint.

    Wenn ich versuche einen Client (Outlook 2013 x86 bzw. 2010 x86) mit Exchange zu verbinden scheitert es immer an der Anmeldung.
    Fehler: „die Aktion kann nicht abgeschlossen werden es steht keine Verbindung mit Microsoft Exchange zur Verfügung“
    [IMG:https://abload.de/img/outlook1pgyin.png]
    Wenn ich jetzt die Verbindung manuell nachbearbeite wie in dem Bild unten dann kann ich eine Verbindung herstellen.
    [IMG:https://abload.de/img/outlook2q9ajw.png]
    „Manuell geht’s“
    [IMG:https://abload.de/img/outlook3ynyih.png]
    Daraufhin habe ich den Online Test (testconnectivity.microsoft.com) gemacht.
    Bild
    mit diesen Fehler: HTTP/1.1 401 Unauthorized

    HTML-Quellcode

    1. Testing the address book "Check Name" operation for user max.mustermann@domain.com against server mail.domain.com.
    2. An error occurred while attempting to resolve the name.
    3. Additional Details
    4. A protocol layer error occured. HttpStatusCode: 401
    5. FailureLID: 47372
    6. FailureInfo:
    7. ###### REQUEST [2017-05-22T08:14:57.2335974Z] ######
    8. POST /mapi/nspi/?mailboxId=25d5fab1-757b-41f2-8fb7-3dae9cc9ef56@domain.com HTTP/1.1
    9. Content-Type: application/octet-stream
    10. User-Agent: MapiHttpClient
    11. X-RequestId: 2a7edbd3-0b3d-4a46-bf02-0c225e68c73a:1
    12. X-ClientInfo: 11fd4de5-62e1-4bad-9bcf-116ac8811a48:1
    13. X-ClientApplication: MapiHttpClient/15.1.819.0
    14. X-RequestType: Bind
    15. Authorization: Basic [truncated]
    16. Host: mail.domain.com
    17. Content-Length: 45
    18. --- REQUEST BODY [+0.494] ---
    19. ..[BODY SIZE: 45]
    20. --- REQUEST SENT [+0.495] ---
    21. ###### RESPONSE [+0:01.002] ######
    22. HTTP/1.1 401 Unauthorized
    23. Connection: keep-alive
    24. request-id: 71ccfbba-f264-42de-8267-b770acd64de9
    25. X-FailureContext: FrontEnd;401;VW5hdXRob3JpemVk;;;;
    26. X-FEServer: EXCSRV01
    27. Content-Length: 0
    28. Date: Mon, 22 May 2017 08:15:05 GMT
    29. Server: Microsoft-IIS/8.5
    30. WWW-Authenticate: Basic [truncated]
    31. X-Powered-By: ASP.NET
    32. --- RESPONSE BODY [+0:01.002] ---
    33. --- RESPONSE DONE [+0:01.002] ---
    34. ###### EXCEPTION THROWN [+0:01.002] ######
    35. HTTP Response Headers:
    36. Connection: keep-alive
    37. request-id: 71ccfbba-f264-42de-8267-b770acd64de9
    38. X-FailureContext: FrontEnd;401;VW5hdXRob3JpemVk;;;;
    39. X-FEServer: EXCSRV01
    40. Content-Length: 0
    41. Date: Mon, 22 May 2017 08:15:05 GMT
    42. Server: Microsoft-IIS/8.5
    43. WWW-Authenticate: Basic realm="10.49.0.16"
    44. X-Powered-By: ASP.NET
    45. HttpStatusCode: 401 Unauthorized
    46. Elapsed Time: 1005 ms.
    Alles anzeigen
    Wenn ich localhost:444/mapi/emsmdb aufrufe bekomme ich aber eine (meiner Meinung nach ) passende Rückantwort.

    [IMG:https://abload.de/img/ie1jqzk2.png]


    Ich habe schon viel im Internet gesucht aber keine Lösung für mein Problem gefunden.
    PS: hier die ausgaben von get-MapiVirtualDirectory, Get-AutodiscoverVirtualDirectory und Test-OutlookConnectivity

    Brainfuck-Quellcode

    1. [PS] C:\Windows\system32>get-MapiVirtualDirectory
    2. Name Server InternalUrl ExternalUrl
    3. ---- ------ ----------- -----------
    4. mapi (Default Web Site) EXCSRV01 https://mail.domain.com/mapi https://mail.domain.com/mapi
    5. [PS] C:\Windows\system32>Get-AutodiscoverVirtualDirectory | select Name, Server, InternalAuth*, ExternalAuth*
    6. Name Server InternalAuthenticationMethods ExternalAuthenticationMethods
    7. ---- ------ ----------------------------- -----------------------------
    8. Autodiscover (Default Web ... EXCSRV01 {Basic, Ntlm, WindowsInteg... {Basic, Ntlm, WindowsInteg...
    9. [PS] C:\Windows\system32>Test-OutlookConnectivity -RunFromServerId excsrv01 -ProbeIdentity OutlookMapiHttpSelfTestProbe
    10. MonitorIdentity StartTime EndTime Result Error Exce
    11. ptio
    12. n
    13. --------------- --------- ------- ------ ----- ----
    14. OutlookMapiHttp.Protocol\OutlookMapiH... 22.05.2017 0... 22.05.2017 0... Succeeded
    Alles anzeigen
    Ich hoffe echt das mir jemand helfen kann !

    Noch ein Paar Infos zum System:
    Windows Server 2012 R2 DE (virtuell) aktuell 16GB ram
    Exchange Server 2016 Std. CU5
    AD ebene min Server 2008
    Getestete Clients:
    Windows 10Pro mit Outlook 2013 x86
    Windows Server 2012R2 mit Outlook 2010 x86

    Schöne Grüße,
    Michael
  • Hallo,

    und willkommen im Forum:

    1. Ist das Zertifikat fehlerfrei und auf die korrekten Namen ausgestellt?
    2. Falls der Client einen Proxy nutzt, ist der Exchange-Server dort als Ausnahme eingerichtet?
    3. Ist Split DNS korrekt eingerichtet.

    4. Und bitte auch die anderen URLs checken und bei Bedarf korrigieren:

    Shell-Script

    1. $servername = "SERVERNAME"
    2. Get-OwaVirtualDirectory -Server $servername | fl internalurl, externalurl
    3. Get-EcpVirtualDirectory -server $servername | fl internalurl, externalurl
    4. Get-WebServicesVirtualDirectory -server $servername | fl internalurl, externalurl
    5. Get-ActiveSyncVirtualDirectory -Server $servername | fl internalurl, externalurl
    6. Get-OabVirtualDirectory -Server $servername | fl internalurl, externalurl
    7. Get-MapiVirtualDirectory -Server $servername | fl internalurl, externalurl
    8. Get-OutlookAnywhere -Server $servername | fl xxternalhostname,internalhostname,ExternalClientsRequireSsl,InternalClientsRequireSsl,ExternalClientAuthenticationMethod
    9. Get-ClientAccessService $servername | fl AutoDiscoverServiceInternalUri
    Grüße aus Berlin schickt Robert
  • Hallo Robert!
    Danke für deine Hilfe.
    Das Zertifikat werde ich noch mit meinen Kollegen prüfen (der macht mehr damit )
    [IMG:https://image.prntscr.com/image/13a2234a15734e918a8d0f57aa4ffa44.png]

    zu den Punkten:
    2. Proxy habe ich bereits auf den Clients wo ich teste deaktiviert.
    3. Ja, also hoffe ich. :)

    Quellcode

    1. Von Intern
    2. H:\>ping wm.XXXX.com
    3. Ping wird ausgeführt für wm.XXXX.com [10.49.0.16] mit 32 Bytes Daten:
    4. Antwort von 10.49.0.16: Bytes=32 Zeit<1ms TTL=127
    5. Antwort von 10.49.0.16: Bytes=32 Zeit<1ms TTL=127
    6. Von Extern
    7. C:\Users\administrator>ping wm.XXXX.com
    8. Ping wird ausgeführt für wm.XXXX.com [195.XX.XX.76] mit 32 Bytes Daten:
    9. Antwort von 195.XX.XX.76: Bytes=32 Zeit=21ms TTL=52
    10. Antwort von 195.XX.XX.76: Bytes=32 Zeit=21ms TTL=52
    Alles anzeigen


    4. müsste auch passen (habe die Domain zensiert)

    Shell-Script

    1. InternalUrl : https://wm.XXXX.com/owa
    2. ExternalUrl : https://wm.XXXX.com/owa
    3. InternalUrl : https://wm.XXXX.com/ecp
    4. ExternalUrl : https://wm.XXXX.com/ecp
    5. InternalUrl : https://wm.XXXX.com/EWS/Exchange.asmx
    6. ExternalUrl : https://wm.XXXX.com/EWS/Exchange.asmx
    7. InternalUrl : https://wm.XXXX.com/Microsoft-Server-ActiveSync
    8. ExternalUrl : https://wm.XXXX.com/Microsoft-Server-ActiveSync
    9. InternalUrl : https://wm.XXXX.com/OAB
    10. ExternalUrl : https://wm.XXXX.com/OAB
    11. InternalUrl : https://wm.XXXX.com/mapi
    12. ExternalUrl : https://wm.XXXX.com/mapi
    13. ExternalHostname : wm.XXXX.com
    14. InternalHostname : wm.XXXX.com
    15. ExternalClientsRequireSsl : True
    16. InternalClientsRequireSsl : True
    17. ExternalClientAuthenticationMethod : Negotiate
    18. AutoDiscoverServiceInternalUri : https://autodiscover.XXXX.com/Autodiscover/Autodiscover.xml
    Alles anzeigen

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von michael2371 ()

  • Moin,

    drei Anmerkungen:
    - das Zertifikat ist offensichtlich intern signiert -> das ist nicht gut und möglichst durch ein externes zu ersetzen (die vielen SAN darin kann man sich auch anders behandeln)
    - in Deinem Outlook-Screenshot schreibst "ext.xxxxx" -> das finde ich in den URLs nicht wieder, alles heißt da "wm.XXXX".
    - der SCP heißt "autodiscover.xxxxx" -> möglich, aber nicht notwendig -> "wm.XXXX" geht auch und ist einfacher intern zu händenl und spart einen Split-DNS-Eintrag (den Du auch nicht zeigst)
    Grüße aus Berlin schickt Robert
  • Hallo,

    immer her damit :) Ich bin um jede Hilfe froh
    - Ja das Zertifikat ist selbst signiert bzw. eigentlich von der Unternehmens CA ausgestellt. -> Was könnte das für Probleme verursachen?
    - ja im Screenshot steht ext. drinnen. mein Fehler! es ist natürlich wm.xxxx.com (was auch drinnen steht - habs gerade nochmal geprüft)
    - ich habe sowohl autodiscover als auch wm als SplitDNS angelegt - ( Hoffentlich auch richtig :) ) hat es einen Nachteil wenn ich autodiscover anstatt wm hernehme ?
    Den Split DNS habe ich so gelöst (Einträge sind mit den anderen DNS Servern Synchron)
    [IMG:https://image.prntscr.com/image/64e8ceb284d540a584074f2faba1b82b.png]

    PS: Gibts die Möglichkeit den Forumsbeitrag zu schützen ? dann kann ich nämlich auch unzensierte ausgaben Posten - ich will nur nicht das die Domains öffentlich auftauchen.


    Nochmal Danke für die schnelle antwort !
  • Ich habe mir jetzt alles noch mal angesehen, kann aber keinen Fehler sehen.

    Vermutlich muss sich das jemand vor Ort anschauen, denn da muss es noch irgendeine Einstellung geben, die nicht dem normalen Standard entspricht. Die muss aber nicht mal in Exchange sein. Das kann auch Client, GPO, Netzwerk, etc. sein.

    Eventuell hilft eine Analyse mit Fiddler.
    Grüße aus Berlin schickt Robert
  • Ich habe nochmal weiter "gebastelt"
    Ich habe unter MAPI die Standard Authentifizierung aktiviert und erhalte keinen Fehler 401 sondern 500. yeahhhh !

    HTML-Quellcode

    1. Testing the address book "Check Name" operation for user max.mustermann@XXXX.com against server wm.XXXX.com.
    2. An error occurred while attempting to resolve the name.
    3. Additional Details
    4. A protocol layer error occured. HttpStatusCode: 500
    5. FailureLID: 47372
    6. FailureInfo:
    7. ###### REQUEST [2017-05-23T11:16:21.3810388Z] ######
    8. POST /mapi/nspi/?mailboxId=25d5fab1-757b-41f2-8fb7-3dae9cc9ef56@XXXX.com HTTP/1.1
    9. Content-Type: application/octet-stream
    10. User-Agent: MapiHttpClient
    11. X-RequestId: 924c5dcc-374d-4054-919f-52ac9c3aa68c:1
    12. X-ClientInfo: b8baf2d2-66a9-44c8-ae36-02be635f88fb:1
    13. X-ClientApplication: MapiHttpClient/15.1.819.0
    14. X-RequestType: Bind
    15. Authorization: Basic [truncated]
    16. Host: wm.XXXX.com
    17. Content-Length: 45
    18. --- REQUEST BODY [+0.268] ---
    19. ..[BODY SIZE: 45]
    20. --- REQUEST SENT [+0.268] ---
    21. ###### RESPONSE [+0:07.096] ######
    22. HTTP/1.1 500 Internal Server Error
    23. Transfer-Encoding: chunked
    24. Connection: keep-alive
    25. request-id: b2054957-7031-4a2f-94ff-ba93ffd06954
    26. X-CalculatedBETarget: excsrv01.XXXX.XXXX.com
    27. X-ServerApplication: Exchange/15.01.0845.034
    28. X-RequestId: 924c5dcc-374d-4054-919f-52ac9c3aa68c:1
    29. X-ClientInfo: b8baf2d2-66a9-44c8-ae36-02be635f88fb:1
    30. X-RequestType: Bind
    31. X-RemotePS-FailureCategory: BackendRehydration-BackendRehydrationException
    32. X-DiagInfo: EXCSRV01
    33. X-BEServer: EXCSRV01
    34. Cache-Control: private
    35. Content-Type: text/html; charset=utf-8
    36. Set-Cookie: MapiRouting=UlVNOjA5ZjY4ODAxLWJmMGUtNGY4Yy1hNjkyLTM0YTZiNjg0MzE0Mzq8I58tzaHUCA==; path=/mapi/; secure; HttpOnly,X-BackEndCookie=25d5fab1-757b-41f2-8fb7-3dae9cc9ef56=u56Lnp2ejJqBx5zHy8+amsvSnJ7PytLLyZ7P0p3MyczSyMmbx5vNncydncjNgYHNz87I0s/J0s3Nq87Oxc7JxczH; expires=Thu, 22-Jun-2017 11:16:38 GMT; path=/mapi; secure; HttpOnly
    37. Server: Microsoft-IIS/8.5
    38. X-AspNet-Version: 4.0.30319
    39. X-FailureContext: BackEnd;500;NTAw;U3lzdGVtLk5ldC5XZWJFeGNlcHRpb246IERlciBSZW1vdGVzZXJ2ZXIgaGF0IGVpbmVuIEZlaGxlciB6dXLDvGNrZ2VnZWJlbjogKDUwMCkgSW50ZXJuZXIgU2VydmVyZmVobGVyLg0KICAgYmVpIFN5c3RlbS5OZXQuSHR0cFdlYlJlcXVlc3QuRW5kR2V0UmVzcG9uc2UoSUFzeW5jUmVzdWx0IGFzeW5jUmVzdWx0KQ0KICAgYmVpIE1pY3Jvc29mdC5FeGNoYW5nZS5IdHRwUHJveHkuUHJveHlSZXF1ZXN0SGFuZGxlci48PmNfX0Rpc3BsYXlDbGFzczI1LjxPblJlc3BvbnNlUmVhZHk+Yl9fMjQoKQ==;;ProtocolError;
    40. X-Powered-By: ASP.NET
    41. X-FEServer: EXCSRV01
    42. Date: Tue, 23 May 2017 11:16:38 GMT
    43. --- RESPONSE BODY [+0:07.096] ---
    44. ..[BODY SIZE: 6178]
    45. # TEXT AUSGESCHNITTEN DA ZU GROß FÜR DAS FORUM#
    46. --- RESPONSE DONE [+0:07.096] ---
    47. ###### EXCEPTION THROWN [+0:07.096] ######
    48. HTTP Response Headers:
    49. Transfer-Encoding: chunked
    50. Connection: keep-alive
    51. request-id: b2054957-7031-4a2f-94ff-ba93ffd06954
    52. X-CalculatedBETarget: excsrv01.XXXX.XXXX.com
    53. X-ServerApplication: Exchange/15.01.0845.034
    54. X-RequestId: 924c5dcc-374d-4054-919f-52ac9c3aa68c:1
    55. X-ClientInfo: b8baf2d2-66a9-44c8-ae36-02be635f88fb:1
    56. X-RequestType: Bind
    57. X-RemotePS-FailureCategory: BackendRehydration-BackendRehydrationException
    58. X-DiagInfo: EXCSRV01
    59. X-BEServer: EXCSRV01
    60. Cache-Control: private
    61. Content-Type: text/html; charset=utf-8
    62. Set-Cookie: MapiRouting=UlVNOjA5ZjY4ODAxLWJmMGUtNGY4Yy1hNjkyLTM0YTZiNjg0MzE0Mzq8I58tzaHUCA==; path=/mapi/; secure; HttpOnly,X-BackEndCookie=25d5fab1-757b-41f2-8fb7-3dae9cc9ef56=u56Lnp2ejJqBx5zHy8+amsvSnJ7PytLLyZ7P0p3MyczSyMmbx5vNncydncjNgYHNz87I0s/J0s3Nq87Oxc7JxczH; expires=Thu, 22-Jun-2017 11:16:38 GMT; path=/mapi; secure; HttpOnly
    63. Server: Microsoft-IIS/8.5
    64. X-AspNet-Version: 4.0.30319
    65. X-FailureContext: BackEnd;500;NTAw;U3lzdGVtLk5ldC5XZWJFeGNlcHRpb246IERlciBSZW1vdGVzZXJ2ZXIgaGF0IGVpbmVuIEZlaGxlciB6dXLDvGNrZ2VnZWJlbjogKDUwMCkgSW50ZXJuZXIgU2VydmVyZmVobGVyLg0KICAgYmVpIFN5c3RlbS5OZXQuSHR0cFdlYlJlcXVlc3QuRW5kR2V0UmVzcG9uc2UoSUFzeW5jUmVzdWx0IGFzeW5jUmVzdWx0KQ0KICAgYmVpIE1pY3Jvc29mdC5FeGNoYW5nZS5IdHRwUHJveHkuUHJveHlSZXF1ZXN0SGFuZGxlci48PmNfX0Rpc3BsYXlDbGFzczI1LjxPblJlc3BvbnNlUmVhZHk+Yl9fMjQoKQ==;;ProtocolError;
    66. X-Powered-By: ASP.NET
    67. X-FEServer: EXCSRV01
    68. Date: Tue, 23 May 2017 11:16:38 GMT
    69. HttpStatusCode: 500 InternalServerError
    70. Elapsed Time: 7098 ms.
    Alles anzeigen
    Ich habe auch zum testen einen proxy dazwischen gehängt, um zu sehen was so durch läuft - hat auch nichts gebracht.
    Gibt es einen Weg die emsmdb/NSPI zb. über den Browser zu testen (außer localhost:444/mapi/ )?
    Welche URL's müssen Welche werte zurückgeben ? wm.xxxx.com/mapi/nspi müsste doch dann die werte zurück bekommen wie localhost:444/mapi/nspi -oder ?

    Danke,
    Michael
  • michael2371 schrieb:

    Ich habe nochmal weiter "gebastelt"
    Ich habe unter MAPI die Standard Authentifizierung aktiviert und erhalte keinen Fehler 401 sondern 500. yeahhhh !

    HTML-Quellcode

    1. Testing the address book "Check Name" operation for user max.mustermann@XXXX.com against server wm.XXXX.com.
    2. An error occurred while attempting to resolve the name.
    3. Additional Details
    4. A protocol layer error occured. HttpStatusCode: 500
    5. FailureLID: 47372
    6. FailureInfo:
    7. ###### REQUEST [2017-05-23T11:16:21.3810388Z] ######
    8. POST /mapi/nspi/?mailboxId=25d5fab1-757b-41f2-8fb7-3dae9cc9ef56@XXXX.com HTTP/1.1
    9. Content-Type: application/octet-stream
    10. User-Agent: MapiHttpClient
    11. X-RequestId: 924c5dcc-374d-4054-919f-52ac9c3aa68c:1
    12. X-ClientInfo: b8baf2d2-66a9-44c8-ae36-02be635f88fb:1
    13. X-ClientApplication: MapiHttpClient/15.1.819.0
    14. X-RequestType: Bind
    15. Authorization: Basic [truncated]
    16. Host: wm.XXXX.com
    17. Content-Length: 45
    18. --- REQUEST BODY [+0.268] ---
    19. ..[BODY SIZE: 45]
    20. --- REQUEST SENT [+0.268] ---
    21. ###### RESPONSE [+0:07.096] ######
    22. HTTP/1.1 500 Internal Server Error
    23. Transfer-Encoding: chunked
    24. Connection: keep-alive
    25. request-id: b2054957-7031-4a2f-94ff-ba93ffd06954
    26. X-CalculatedBETarget: excsrv01.XXXX.XXXX.com
    27. X-ServerApplication: Exchange/15.01.0845.034
    28. X-RequestId: 924c5dcc-374d-4054-919f-52ac9c3aa68c:1
    29. X-ClientInfo: b8baf2d2-66a9-44c8-ae36-02be635f88fb:1
    30. X-RequestType: Bind
    31. X-RemotePS-FailureCategory: BackendRehydration-BackendRehydrationException
    32. X-DiagInfo: EXCSRV01
    33. X-BEServer: EXCSRV01
    34. Cache-Control: private
    35. Content-Type: text/html; charset=utf-8
    36. Set-Cookie: MapiRouting=UlVNOjA5ZjY4ODAxLWJmMGUtNGY4Yy1hNjkyLTM0YTZiNjg0MzE0Mzq8I58tzaHUCA==; path=/mapi/; secure; HttpOnly,X-BackEndCookie=25d5fab1-757b-41f2-8fb7-3dae9cc9ef56=u56Lnp2ejJqBx5zHy8+amsvSnJ7PytLLyZ7P0p3MyczSyMmbx5vNncydncjNgYHNz87I0s/J0s3Nq87Oxc7JxczH; expires=Thu, 22-Jun-2017 11:16:38 GMT; path=/mapi; secure; HttpOnly
    37. Server: Microsoft-IIS/8.5
    38. X-AspNet-Version: 4.0.30319
    39. X-FailureContext: BackEnd;500;NTAw;U3lzdGVtLk5ldC5XZWJFeGNlcHRpb246IERlciBSZW1vdGVzZXJ2ZXIgaGF0IGVpbmVuIEZlaGxlciB6dXLDvGNrZ2VnZWJlbjogKDUwMCkgSW50ZXJuZXIgU2VydmVyZmVobGVyLg0KICAgYmVpIFN5c3RlbS5OZXQuSHR0cFdlYlJlcXVlc3QuRW5kR2V0UmVzcG9uc2UoSUFzeW5jUmVzdWx0IGFzeW5jUmVzdWx0KQ0KICAgYmVpIE1pY3Jvc29mdC5FeGNoYW5nZS5IdHRwUHJveHkuUHJveHlSZXF1ZXN0SGFuZGxlci48PmNfX0Rpc3BsYXlDbGFzczI1LjxPblJlc3BvbnNlUmVhZHk+Yl9fMjQoKQ==;;ProtocolError;
    40. X-Powered-By: ASP.NET
    41. X-FEServer: EXCSRV01
    42. Date: Tue, 23 May 2017 11:16:38 GMT
    43. --- RESPONSE BODY [+0:07.096] ---
    44. ..[BODY SIZE: 6178]
    45. # TEXT AUSGESCHNITTEN DA ZU GROß FÜR DAS FORUM#
    46. --- RESPONSE DONE [+0:07.096] ---
    47. ###### EXCEPTION THROWN [+0:07.096] ######
    48. HTTP Response Headers:
    49. Transfer-Encoding: chunked
    50. Connection: keep-alive
    51. request-id: b2054957-7031-4a2f-94ff-ba93ffd06954
    52. X-CalculatedBETarget: excsrv01.XXXX.XXXX.com
    53. X-ServerApplication: Exchange/15.01.0845.034
    54. X-RequestId: 924c5dcc-374d-4054-919f-52ac9c3aa68c:1
    55. X-ClientInfo: b8baf2d2-66a9-44c8-ae36-02be635f88fb:1
    56. X-RequestType: Bind
    57. X-RemotePS-FailureCategory: BackendRehydration-BackendRehydrationException
    58. X-DiagInfo: EXCSRV01
    59. X-BEServer: EXCSRV01
    60. Cache-Control: private
    61. Content-Type: text/html; charset=utf-8
    62. Set-Cookie: MapiRouting=UlVNOjA5ZjY4ODAxLWJmMGUtNGY4Yy1hNjkyLTM0YTZiNjg0MzE0Mzq8I58tzaHUCA==; path=/mapi/; secure; HttpOnly,X-BackEndCookie=25d5fab1-757b-41f2-8fb7-3dae9cc9ef56=u56Lnp2ejJqBx5zHy8+amsvSnJ7PytLLyZ7P0p3MyczSyMmbx5vNncydncjNgYHNz87I0s/J0s3Nq87Oxc7JxczH; expires=Thu, 22-Jun-2017 11:16:38 GMT; path=/mapi; secure; HttpOnly
    63. Server: Microsoft-IIS/8.5
    64. X-AspNet-Version: 4.0.30319
    65. X-FailureContext: BackEnd;500;NTAw;U3lzdGVtLk5ldC5XZWJFeGNlcHRpb246IERlciBSZW1vdGVzZXJ2ZXIgaGF0IGVpbmVuIEZlaGxlciB6dXLDvGNrZ2VnZWJlbjogKDUwMCkgSW50ZXJuZXIgU2VydmVyZmVobGVyLg0KICAgYmVpIFN5c3RlbS5OZXQuSHR0cFdlYlJlcXVlc3QuRW5kR2V0UmVzcG9uc2UoSUFzeW5jUmVzdWx0IGFzeW5jUmVzdWx0KQ0KICAgYmVpIE1pY3Jvc29mdC5FeGNoYW5nZS5IdHRwUHJveHkuUHJveHlSZXF1ZXN0SGFuZGxlci48PmNfX0Rpc3BsYXlDbGFzczI1LjxPblJlc3BvbnNlUmVhZHk+Yl9fMjQoKQ==;;ProtocolError;
    66. X-Powered-By: ASP.NET
    67. X-FEServer: EXCSRV01
    68. Date: Tue, 23 May 2017 11:16:38 GMT
    69. HttpStatusCode: 500 InternalServerError
    70. Elapsed Time: 7098 ms.
    Alles anzeigen
    Ich habe auch zum testen einen proxy dazwischen gehängt, um zu sehen was so durch läuft - hat auch nichts gebracht.
    Gibt es einen Weg die emsmdb/NSPI zb. über den Browser zu testen (außer localhost:444/mapi/ )?
    Welche URL's müssen Welche werte zurückgeben ? wm.xxxx.com/mapi/nspi müsste doch dann die werte zurück bekommen wie localhost:444/mapi/nspi -oder ?

    Danke,
    Michael
    Nochmal eine Verständnis frage hinterher:
    wenn ich excsrv01.xxxx.XXXX.com:444/map…9cc9ef56@XXXX.com[/email] aufrufe bekomme ich das:

    Quellcode

    1. Exchange MAPI/HTTP Connectivity Endpoint
    2. Version: 15.1.845.34
    3. Vdir Path: /mapi/nspi/
    4. User: xxxx\micwrde
    5. UPN:
    6. SID: S-1-5-21-462151714-2984779906-843723717-4122
    7. Organization:
    8. Authentication: Negotiate
    9. PUID:
    10. TenantGuid::
    11. Cafe:
    12. Mailbox: excsrv01.xxxx.XXXX.com
    13. Created: 23.05.2017 12:13:33
    Alles anzeigen
    das müsste ich doch auch unter der wm.XXXX.com/mapi/nspi/?mailbox…9cc9ef56@XXXX.com[/email] erhalten - oder?

    ich bekomme aber das:
    [IMG:https://image.prntscr.com/image/94c7ceced75846b0a87b055a24b406a2.png]

    Grüße,
    Michael