Nach Migration 2010->2016 kein Login mit Outlook möglich

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • So, es gibt Neuigkeiten:

    Hatte heute morgen die Idee testweise mal für einen Nutzer (mich selbst) "MapiOverHttp" zu deaktivieren per

    Quellcode

    1. Set-CASMailbox user -MapiHttpEnabled $false

    Dies führte dazu dass ich mich mit diesem Benutzer sofort wieder bei Outlook (2016) ohne Passwort-Abfrage einloggen konnte. Auch meine öffentlichen Ordner (welche noch auf dem Exchange 2010 liegen) sind nutzbar. Soweit so gut, ABER:

    Bisher habe ich bei 10 weiteren Nutzern diese Umstellung versucht und nur bei einem einzigen hat das dann auch geklappt. Bei allen anderen kommt entweder weiterhin die Nutzername / Passwort Abfrage und dann kann Outlook nicht mal mehr gestartet werden oder - falls Outlook nach Abbrechen der Passwortabfrage sich noch öffnet - ich kann dann in den Verbindungseinstellungen (STRG + Klick auf das Outlooksymbol in der Taskleiste) sehen dass als Protokoll "HTTP" benutzt wird und die Auth* fehlschlägt.

    Weiterhin versucht habe ich:

    Quellcode

    1. Set-OrganizationConfig -MapiHttpEnable $false
    2. Set-CASMailbox [alle anderen User] -MapiHttpEnable $false
    Zudem habe ich auf den Client Rechnern in der Registry den Eintrag gesetzt "DWORD: MapiHttpDisabled" = 1 unter HKLU\Software\Microsoft\Exchange


    Was mir aufgefallen ist:
    Im EAC unter Postfächer waren die Einstellungen "Mapi" immer noch auf "enabled" gesetzt. Habe das auch dort umgestellt, auch keine Auswirkung.


    Ach so: Der auch funktionierende Nutzer ist KEIN Admin, mein Konto schon; diese Nutzer und alle anderen auch sind bereits mit der Mailbox auf 2016 migriert. Jeder Nuzter hat eigenen PC. Alle nutzen Windows 10 + Outlook 2016.



    Mal davon abgesehen dass es sicher keine Dauerlösung sein sollte, Mapi zu deaktivieren, so hilft es doch momentan extrem weiter da die Mitarbeiter wieder Outlook nutzen können.
    Worauf muss ich noch achten damit ich für einen Nutzer Mapi effektiv deaktivieren kann ?
  • Stellt sich ja die Frage, warum bei dir nicht Mapi/http funktioniert? Wie ist dieses Virtuelle Verzeichnis denn konfiguriert?
    Abgesehen davon wenn du es global deaktivierst, brauchst du es LOGISCHERWEISE nicht mehr auf der CASMailbox deaktivieren. Mach das wieder rückgängig, denn das fällt dir zwangsläufig in der Zukunft wieder auf die Füße. Das sind wieder die typischen (bereits angesprochenen) Panikaktionen. Dann auch noch am Client per Registry ausschalten. :| Mapi in den Eigenschaften der Mailbox ist wiederum was ganz anderes. Nicht einfach irgendwo rumpopeln... Im Endeffekt kann man aber hier im Forum leider nur "bedingt" helfen, denn bei so einer etwas größeren und grundlegenden Umstellung lassen sich mögliche Fehler im Verlauf der Migration nur schwer identifizieren.

    Hast du keine Möglichkeit externe Unterstützung hinzuzuziehen?

    Bye
    Norbert
  • mw42 schrieb:

    Mal davon abgesehen dass es sicher keine Dauerlösung sein sollte, Mapi zu deaktivieren, so hilft es doch momentan extrem weiter da die Mitarbeiter wieder Outlook nutzen können.
    Es ist mir durchaus bewusst dass
    • es keine SINNVOLLE Lösung ist
    • es besser wäre die Ursache des Problems mit MAPI zu finden
    Momentan muss ich zusehen dass die Mitarbeiter erstmal wieder ihr Outlook nutzen können. Wenn das bedeutet dass ich für einen kurzen Zeitraum auf Mapi verzichten muss dann nehme ich das gern in Kauf. Vor allem verschafft mir das etwas Zeit um weiter an der Mapi Problematik zu arbeiten.

    Externe Hilfe habe ich kontaktiert.

    Es hätte ja möglich sein können dass hier im Forum jemand einen effektiven Rat zur der "Mapi lässt sich nicht abschalten" Thematik weiss. Das - wie gesagt - hälfe mir im Moment weiter.
  • Nochmal, wenn du es serverseitig abschaltest, sind die anderen zwei Schritte einfach überflüssig und verursachen später nur Probleme, wenn man es wieder aktivieren will und dabei vergißt, dass man im Stress der Migration viel zu viel abgeschaltet und rumprobiert hat.

    Und effektiven Rat in so einer Situation zu geben ist eben schwer. Du merkst ja selbst, dass man/ich hier immer wieder einzelne Informationen nachgefragt habe, weil es eben nicht aus deiner Beschreibung hervorgeht. Dann kannst du ja mal berichten, was die externe Hilfe rausfindet.

    Viel Erfolg.

    Bye
    Norbert
  • So, mal ein Update zu dieser Thematik:

    Aktuell kann ich Outlook wieder nutzen, allerdings für alle Benutzer nur mit "Set-CASMailbox <user> -MapiHttpEnabled $false".

    Das Problem scheint an unserer Firewall zu liegen (Sophos UTM). Bei dieser wird Exchange 2016 offiziell gar nicht unterstützt :cursing: Muss man drauf kommen. Es gibt einen Artikel als Workaround von Sophos dafür; nach EInrichtung ging dann der Zugriff von aussen nicht mehr, aber das ist grad erstmal egal. Sophos Support ist informiert und wird sich bald kümmern.

    Bis zu dem Zeitpunkt (Outlook ging intern nicht, FIrewall noch nicht umgestellt) ging es von aussen nämlich sehr gut. Autoconfig und sowas hat alles prima geklappt, und das hat mich dann auf den Fehler in der internen Kommunikation gebracht.

    Ich berichte später nochmal...
  • Wenn von intern die FIrewall (wahrscheinlich EHER der Proxy) dazwischenfunkt, muß man logischerweise dafür sorgen, dass es Proxyausnahmen (Nach Migration 2010->2016 kein Login mit Outlook möglich) am Client gibt. Nicht, dass das ganz vorn im Thread schon so steht. Welche Sophos Version setzt du ein? Ich würde sagen, alles Kleinigkeiten, die man hätte vorher klären könnte, wenn man nicht immer nur die halbe Information erhalten würde. :)