Exchange 2007 auf 2013 Migration

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Exchange 2007 auf 2013 Migration

    Hi zusammen,

    ich habe nun einen Exchange Server 2007 auf einen 2013 migriert, um diesen zu einem späteren Zeitpunkt auf einen 2016 hochzuziehen.
    Nun sind bei der Migration vom 2007 auf den 2013 ein zwei Fragen aufgetreten:

    1.) Nach der Migration werden alle Postfächer korrekt angezeigt, die Empfangs und Sendeconnectoren werden ebenfalls korrekt im ECP angezeigt. Hierzu die erste Frage:

    Im Exchange Server 2007 gibt es im STandard nur zwei Empfangsconnectoren. Client und Default. Auf dem Exchange Server 2013 gibt es aber per Default 5 Empfangsconnectoren.

    Wie oben bereits geschrieben, sind nun auf dem Exchange 2013 Server nur die zwei Empfangsconnectoren vom Exchange 2007 vorhanden und nicht fünf. Müssen hier weitere konfiguriert werden?
    Müssen hier die vom 2007er entfernt werden und alle fünf Standard Connectoren vom Exchange 2013 neu konfiguriert werden?


    2.) Ich habe mich ein wenig an dieser Anleitung entlang gehangelt:

    blogs.technet.microsoft.com/me…e-2007-to-2013-migration/

    Hierzu eine Frage auf die verlinkte Seite. In dem Step 3 zieht er die Client Access vom alten Server (Exchange 2007) auf den neuen Server (2013) um.
    Was genau wird hier gemacht? Werden im alten Server in den CAS Einstellungen, die URLS z.B. für Autodiscover auf den neuen umgestellt?


    Set-ActiveSyncVirtualDirectory –Identity “e12-01\Microsoft-Server-ActiveSync (Default Web Site)” –ExternalUrl $Null –InternalUrl legacy.contoso.com/Microsoft-Server-ActiveSync
    Was wird z.B. genau mit diesem Befehlt gemacht. External und InternalURL ist klar, eher der vordere Teil? Was ist mit e12.01 gemeint?

    3.) Der Versand und Empfang unter den Exchange Server hat natürlich nicht funktioniert.

    Hier hat die Authentifizierung bei "Exchange Server " gefehlt. Dies ist sowieso nur für die Koexistenz relevant.

    4.) Ebenfalls wird in diesem Artikel dies ausgeführt:




    TMG Rules:

    Create/update your TMG publish rules
    For Exchange 2007 update your publish rules to accept connections for Legacy name space

    Was ist hiermit genau gemeint?


    Danke im VOraus für eure Hilfe.

    Grüße Phil
  • Gerber schrieb:

    Wie oben bereits geschrieben, sind nun auf dem Exchange 2013 Server nur die zwei Empfangsconnectoren vom Exchange 2007 vorhanden und nicht fünf. Müssen hier weitere konfiguriert werden?
    Müssen hier die vom 2007er entfernt werden und alle fünf Standard Connectoren vom Exchange 2013 neu konfiguriert werden?
    Connectoren sind Serverbezogen. Heißt, du mußt auch den richtigen Server in der Webconsole auswählen, damit er dir die entsprechenden Connectoren anzeigt. Alternativ was gibt dir ein Get-Receiveconnector am Exchange 2013 zurück? Sollten tatsächlich nur zwei auf dem 2013er vorhanden sein, müssen die restlichen Standardconnectoren noch erzeugt werden.


    Gerber schrieb:

    Was wird z.B. genau mit diesem Befehlt gemacht. External und InternalURL ist klar, eher der vordere Teil? Was ist mit e12.01 gemeint?
    e12.01 ist der/sein Servername.

    Gerber schrieb:

    Was ist hiermit genau gemeint?
    Setzt du ein TMG = Threat Management Gateway 2010 ein? Falls nein, dann ist es egal.

    Bye
    Norbert

    PS: Das waren mehr als 2 Fragen. ;)
  • Hi Norbert,

    danke dir Vorweg für die schnelle Antwort, wie immer ^^

    NorbertFe schrieb:

    Connectoren sind Serverbezogen. Heißt, du mußt auch den richtigen Server in der Webconsole auswählen, damit er dir die entsprechenden Connectoren anzeigt. Alternativ was gibt dir ein Get-Receiveconnector am Exchange 2013 zurück? Sollten tatsächlich nur zwei auf dem 2013er vorhanden sein, müssen die restlichen Standardconnectoren noch erzeugt werden.
    Werde ich später gleich nachsehen, wenn ich in der Firma bin. Verdammt logisch, vermutlich habe ich den Server nicht ausgewählt 8| . Werde lieber über die Powershell gehen.


    NorbertFe schrieb:

    e12.01 ist der/sein Servername.

    Verstanden. Habe ich mir fast gedacht, allerdings war ich mir nicht zu 100 Prozent sicher. Was macht er denn dann genau in diesem Schritt. Setzt er wirklich die URLs auf dem alten Exchange Server auf den neuen Server um?
    Bedeutet, dass der alte nicht mehr über OWA, OBA, AUtodiscover usw erreichbar ist?

    Ist dies wirklich notwendig?


    NorbertFe schrieb:

    Setzt du ein TMG = Threat Management Gateway 2010 ein? Falls nein, dann ist es egal.
    In diesem Fall nicht. :rolleyes:


    NorbertFe schrieb:

    PS: Das waren mehr als 2 Fragen.
    Uppps, ist mir irgendwie im Rausch passiert :P :D :D

    Grüße
    Phil
  • Gerber schrieb:

    Was macht er denn dann genau in diesem Schritt. Setzt er wirklich die URLs auf dem alten Exchange Server auf den neuen Server um?
    Ja natürlich. Üblicherweise hat man ja einen "generischen" Namen wie bspw. mail.domain.tld usw. dann müßte man nämlich nur im DNS die IP Adresse schwenken und im neuen Server diesen Namen eintragen. Da aber viele Exchange 2007 Admins damals überhaupt nicht verstanden haben, wie der "Kram" mit den virtuellen Verzeichnissen funktioniert, wird das in dem Zuge auch mit glattgezogen werden (habe mir die Anleitung jetzt nicht durchgelesen).


    Gerber schrieb:

    Bedeutet, dass der alte nicht mehr über OWA, OBA, AUtodiscover usw erreichbar ist?
    Nein, das bedeutet, dass der Client im Autodiscoverprozess keine Daten mehr vom alten Server geliefert bekommt. Das heißt nicht, dass OWA/OAB usw. nicht erreichbar wären.



    Gerber schrieb:

    Ist dies wirklich notwendig?
    Ja. Was glaubst du denn? ;) Der einzige Schritt, den man sich bei kleinen und kurzen MIgrationen sparen kann (meiner Meinung nach) ist der Schritt mit der Legacy Domain, denn im Zweifel kann man den Leuten erklären, dass OWA mal eben nicht verfügbar ist für einen Zeitraum.

    Bye
    Norbert
  • NorbertFe schrieb:


    Ja natürlich. Üblicherweise hat man ja einen "generischen" Namen wie bspw. mail.domain.tld usw. dann müßte man nämlich nur im DNS die IP Adresse schwenken und im neuen Server diesen Namen eintragen. Da aber viele Exchange 2007 Admins damals überhaupt nicht verstanden haben, wie der "Kram" mit den virtuellen Verzeichnissen funktioniert, wird das in dem Zuge auch mit glattgezogen werden (habe mir die Anleitung jetzt nicht durchgelesen)
    Okay. Dies mit dem Namen ist klar. Leier findet man sowas immer häufiger noch vor, haste Recht.
    In der Anleitung geht er eben auf den alten Exchange Server und setzt die URls sozusagen auf den neuen um, richtig.

    Die Frage ist, muss dies auf dem alten Server überhaupt noch erledigt werden, wenn dieser sowieso außer Betrieb genommen wird? Auf dem neuen Server müssen die URLs sowieso angepasst werden. Am besten auf den dns Namen. Z.B. mail.domain.de


    NorbertFe schrieb:

    Nein, das bedeutet, dass der Client im Autodiscoverprozess keine Daten mehr vom alten Server geliefert bekommt. Das heißt nicht, dass OWA/OAB usw. nicht erreichbar wären.
    Ok. Verstanden.


    NorbertFe schrieb:

    Ja. Was glaubst du denn? Der einzige Schritt, den man sich bei kleinen und kurzen MIgrationen sparen kann (meiner Meinung nach) ist der Schritt mit der Legacy Domain, denn im Zweifel kann man den Leuten erklären, dass OWA mal eben nicht verfügbar ist für einen Zeitraum.
    Perfekt...

    Grüße
    Phil
  • NorberFe schrieb:

    Ja, weil du sonst mit hoher Wahrscheinlichkeit Fehler im Outlook sehen wirst. Was genau stört dich denn daran?
    Eigentlich stört mich nichts daran :-). Will nur genau verstehen, was dahinter steckt...

    Eine weitere Frage hätte ich noch:

    Ich kann momentan von Benutzern, welche auf dem neuen Server sind, Mails zum alten senden.

    Allerdings kann ich keine E-Mails vom Exchange Server 2007 -> 2013 senden. ?? Hast du hierzu grad auf Anhieb eine Idee?
  • Sauber xD.

    Auf alle Fälle hängen alle Mails auf dem 2007er in der Warteschlange fest. Auch welche, die von Extern kommen (Logischerweise).

    Wenn ich mit Telnet eine Mail zum Exchange 2013 sende bekomme ich folgende Fehlermeldung:

    Queued mail for delivery

    500 5.3.3 Unrecognized command