Installation Exchange-Server

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Das kommt darauf an... Eventuell hast Du bei Deinem Webseiten-Provider kostenlose oder günstige Zertifikat.

    Wobei Du zwei DNS-Namen benutzt. Das ist ein wenig teurer und bei guter Exchange-Konfiguration auch nicht unbedingt notwendig.

    Ansonsten gibt es wirklich sehr viele Reseller.

    psw.net/ -> 1 Namen = LITE = 15 Euro pa, 2 Namen = BRONZE = 39 Euro.
    gogetssl.com/ -> 1 Name = Commode Free SSL = kostenlos (aber imho nur für ein Jahr möglich); 1 Namen = GGSSL = 18 $ pa.1
    Grüße aus Berlin schickt Robert
  • Commode Free SSL habe ich auch gerade schon gesehen.

    Aber mal eine blöde Frage, mir wäre SSL bzw. https:// nicht so wichtig. Könnte ich da diesen Schritt in der Anleitung auch einfach überspringen und mit der Anpassung der virtuellen Verzeichnisse weitermachen oder wird zwingend ein Zertifikat benötigt?

    Würde ein selbstsigniertes auch reichen? Weil dann kann ich ja dann einfach über die interne Zertifizierungsstelle erstellen oder?

    Grüße
  • Wie wärs, du machst es richtig und lernst was dabei? Ja Zertifikate sind absolutes Grund-know-how für Exchange und viele weitere Dinge. Wenn du es mit einem selfsigned probieren willst, dann tu das, aber dann wundere dich nicht, warum du wieder andere Fehlermeldungen bekommst. Die kann man auch alle wegbekommen, aber für den Aufwand könnte man sich auch einfach ein Zertifikat besorgen.
  • Ihr habt Recht und ich habe mir das Zertifikat offiziell abschließen lassen.

    Beim Setzen der virtuellen Verzeichnisse habe ich wieder ein paar Warnungen und einen Fehler bekommen:

    "WARNUNG: Sie haben „InternalURL“ oder „ExternalURL“ für das virtuelle OWA-Verzeichnis geändert. Nehmen Sie dieselbe
    Änderung für das virtuelle ECP-Verzeichnis auf derselben Website vor.
    WARNUNG: Das Cmdlet "Get-ClientAccessServer" wird in einer künftigen Version von Exchange entfernt. Verwenden Sie
    stattdessen das Cmdlet "Get-ClientAccessService". Wenn in Skripts das Cmdlet "Get-ClientAccessServer" verwendet wird,
    aktualisieren Sie die Skripts, sodass sie das Cmdlet "Get-ClientAccessService" verwenden. Weitere Informationen finden
    Sie unter "http://go.microsoft.com/fwlink/p/?LinkId=254711".
    WARNUNG: Das Cmdlet "Set-ClientAccessServer" wird in einer künftigen Version von Exchange entfernt. Verwenden Sie
    stattdessen das Cmdlet "Set-ClientAccessService". Wenn in Skripts das Cmdlet "Set-ClientAccessServer" verwendet wird,
    aktualisieren Sie die Skripts, sodass sie das Cmdlet "Set-ClientAccessService" verwenden. Weitere Informationen finden
    Sie unter "http://go.microsoft.com/fwlink/p/?LinkId=254711".
    Zum Konfigurieren der Outlook Anywhere-Funktion mit "ExternalHostname" müssen Sie auch den Parameter
    "ExternalClientsRequireSsl" angeben, um anzuzeigen, ob SSL erforderlich ist.
    + CategoryInfo : InvalidArgument: (SERVER3\Rpc (Default Web Site):ADObjectId) [Set-OutlookAnywhere],
    ArgumentException
    + FullyQualifiedErrorId : [Server=SERVER3,RequestId=fea65434-0161-4f9b-ae03-a7399e88f8bc,TimeStamp=14.01.2019
    17:55:58] [FailureCategory=Cmdlet-ArgumentException] C0CAF652,Microsoft.Exchange.Management.SystemConfigurationTa
    sks.SetRpcHttp
    + PSComputerName : server3.gmbh.local"

    Bei den Warnungen muss ich doch den gleichen Befehl einfach mit "Get-ClientAccessService" statt "Get-ClientAccessServer" durchführen richtig? Dann dürften die Warnungen nicht mehr kommen.

    Aber was muss ich bei dem letzten Fehler machen? Anscheinend scheint da noch etwas zu fehlen?


    Grüße
  • Okay, die anderen Warnungen sind nun behoben.

    Ich dachte nur weil das hier in rot geschrieben ist:

    "Zum Konfigurieren der Outlook Anywhere-Funktion mit "ExternalHostname" müssen Sie auch den Parameter
    "ExternalClientsRequireSsl" angeben, um anzuzeigen, ob SSL erforderlich ist.
    + CategoryInfo : InvalidArgument: (SERVER3\Rpc (Default Web Site):ADObjectId) [Set-OutlookAnywhere],
    ArgumentException
    + FullyQualifiedErrorId : [Server=SERVER3,RequestId=fea65434-0161-4f9b-ae03-a7399e88f8bc,TimeStamp=14.01.2019
    17:55:58] [FailureCategory=Cmdlet-ArgumentException] C0CAF652,Microsoft.Exchange.Management.SystemConfigurationTa
    sks.SetRpcHttp
    + PSComputerName : server3.gmbh.local"

    Wäre es wichtig das richtig zu konfigurieren. Was fehlt denn an dieser Stelle, oder kann ich das vernachlässigen?


    Beim letzten Teil der Anleitung, wie sollte es anders sein, auf wieder eine Meldung:

    "Neues Zertifikat an die Exchangedienste binden:"

    Source Code

    1. # Exchangezertifikate ausgeben, damit der Thumprint ermittelt werden kann
    2. Get-ExchangeCertificate
    3. # Neues Zertifikat aktivieren und an die Dienste binden
    4. Enable-ExchangeCertificate -Thumbprint FD1FA02B8C74DEB554FBDD4D5FE5442B541E6748 -Service IIS, IMAP, SMTP, POP
    "Ein spezieller RPC-Fehler ist auf Server SERVER3 aufgetreten: Das Zertifikat mit dem Fingerabdruck

    'FD1FA02B8C74DEB554FBDD4D5FE5442B541E6748' wurde gefunden, ist jedoch für die Verwendung mit Exchange Server nicht
    gültig (Begründung: PrivateKeyMissing).
    + CategoryInfo : NotSpecified: (:) [Enable-ExchangeCertificate], InvalidOperationException
    + FullyQualifiedErrorId : [Server=SERVER3,RequestId=993f0bd0-1264-47fa-8aee-3716db0199a0,TimeStamp=14.01.2019
    18:29:52] [FailureCategory=Cmdlet-InvalidOperationException] 9725DB64,Microsoft.Exchange.Management.SystemConfigu
    rationTasks.EnableExchangeCertificate
    + PSComputerName : server3.gmbh.local"


    Es scheint verhext :(



    Grüße
  • Okay, die Meldung mit Anywhere habe ich jetzt auch weg.

    Bleibt noch die letzte mit dem Fingerprint.

    "Ein spezieller RPC-Fehler ist auf Server SERVER3 aufgetreten: Das Zertifikat mit dem Fingerabdruck

    'FD1FA02B8C74DEB554FBDD4D5FE5442B541E6748' wurde gefunden, ist jedoch für die Verwendung mit Exchange Server nicht
    gültig (Begründung: PrivateKeyMissing).
    + CategoryInfo : NotSpecified: (:) [Enable-ExchangeCertificate], InvalidOperationException
    + FullyQualifiedErrorId : [Server=SERVER3,RequestId=993f0bd0-1264-47fa-8aee-3716db0199a0,TimeStamp=14.01.2019
    18:29:52] [FailureCategory=Cmdlet-InvalidOperationException] 9725DB64,Microsoft.Exchange.Management.SystemConfigu
    rationTasks.EnableExchangeCertificate
    + PSComputerName : server3.gmbh.local"


    Grüße