Exchange mit Outlook-Anbindung

  • Hi Hi,


    da ich nur bedingt weiß was ich hier tue, weiß ich somit auch nicht wonach ich suchen muss :)


    Daher verzeit es mir wenn es die Frage schon mal gab :)


    Ich bin eigentlich Linux administrator, da ich Zugriff auf die passenden Lizenzen habe, dachte ich mir, schauste doch mal übern Tellerrand und beschäftigst dich mit Exchange.


    Gesagt getan, das eigentliche Mailen, OWA etc funktioniert, mein Problem ist:


    Ich kann den Account nicht im Outlook hinzufügen. Dort kommt die Meldung:


    "Die Aktion kann nicht abgeschlossen werden. Es steht keine Verbindung mit Microsoft Exchange zur Verfügung. Outlook muss im Onlinemodus oder verbunden sein, um diesen VOrgang abzuschließen"


    Folgendes Setup hab ich hier:


    ipfire lokal (192.168.178.1 + dyn IP von Telekom)
    Main-Domaincontroller (192.168.178.7)
    Terminalserver (192.168.178.8)


    Da dies hier lokal steht und ich keine fest IP hab habe ich mit ESX u. IPSEc mein Netzwerk mit einem Root-Server erweitert:


    ipfire (192.168.0.1 + feste IP vom Root-Server, macht Portforwarding auf den Ex)
    zweiter Domaincontroller (192.168.0.7)
    Exchange-Server (192.168.0.8)


    Die Verbindung ist stabil, ich kann fröhlich über DNS / IP pingen.


    Ich hab mir sogar, da es das gerade für 49€ gab, für die Domain ein *.Wildcard-SSL-Certificat gekauft welches auch eingebunden ist und läuft.


    Outlook-Anywhere ist aktiviert


    Das Micorost Connectivity-Tool sagt: Alles i.O Verbindung kann hergestellt werden.


    Da mir das tierisch gegen den Strich geht das etwas nicht funktioniert:
    WO ist der Fehler?!


    Folgende Daten versuche ich im Outlook einzugeben:


    -> Verbindung mit Exchange
    -> Server: exchange.domain.tld
    -> Username: domain.lokal\Username
    -> Password: Password


    Dann kommt die oben genannte Fehlermeldung. Auch wenn ich das via Activ-Sync versuche.


    Grüße

  • Hi,


    so .. ich habs nun mal, nachdem es mit 2 Androids nicht geklappt hat, mit nem iOS probiert:


    DAS funktioniert.


    Das iPhone konnte sich komplett syncen, empfang und versenden klappt auch.


    NUN bin ich verwirrt.


    Grüße

  • Moin,


    und willkommen im Forum.


    Vorab: Es ist nicht schlimm, dass Du Dich mit Windows und Exchange nicht auskennst, jeder fängt mal an.


    Allerdings ist Exchange für den Anfang nicht das beste Produkt. Es ist eines der komplexesten von Microsoft, für das man viel Grundlagenwissen zu Windows, AD, Zertifikaten, Protokollen und natürlich auch Exchange braucht.


    Ein Forum kann prinzipiell kein Grundlagenwissen vermitteln.


    Outlook verbindet sich automatisch mit Exchange, sobald sich Outlook auf einem Domänen-PC gestartet wird und der User als Dom-User angemeldet ist.


    Diesen Vorgang nennt man Autodiscover und er findet, wie ein paar andere, via HTTPS statt.


    Damit er funktioniert braucht er zwei Dinge:
    - ein korrektes Zertifikat im Exchange, dem der Client ohne Fehlermeldung vertraut (zum Testen OWA nehmen, es da keinen Fehler beim Aufruf von OWA geben).
    - korrekt konfigurierte URLs, die dem Client geschickt werden, und die zum Zertifkat passen müssen


    Für das Zertifikat ist der beste Weg, Du installierst auf dem DC eine AD-integrierte CA und verteilst das Root-Cert dann via GPO.


    Es gibt zwar auch Anleitungen mit Self-Signed Zertifikaten, die sind aber seitens Exchange nicht supported und funktionieren mit Outlook Anywhere offiziell nicht fehlerfrei.


    Du kannst natürlich auch ein externes kaufen.


    Spiel mal den Exchange Deployment Assistenten durch:
    http://technet.microsoft.com/en-us/office/dn756393.aspx


    Da werden auch die URLs konfiguriert und er ist ein recht guter Startpunkt.

    Grüße aus Berlin schickt Robert

  • Hi,


    danke für die Antwort.


    Naja .. mit Kleinkram kann ja jeder anfangen ;)


    Zum Zertifikat: Ich hab eins von Comodo gekauft, für 49€, das läuft. Ich wollte den Fehler des Certificates auf jedenfall umgehen ;)


    Mir geht es aber auch um die PCs die nicht in der Domain sind. Ich hab hier ein externes Outlook2013 welches mir ebenfalls sagt: "Die Aktion kann nicht abgeschlossen werden. Es steht keine Verbindung mit Microsoft Exchange zur Verfügung. Outlook muss im Onlinemodus oder verbunden sein, um diesen VOrgang abzuschließen"


    Wie gesagt, das iPhone funktioniert problemlos.


    Das verwundert mich.


    Deinen Link führe ich mir aber auch noch zu gemüte :) Danke dafür.


    Grüße

  • Moin,


    das iPhone funktioniert auch nicht "problemlos". Du kannst den Fehler dort nur einfach ignorieren. Das geht bei Outlook nicht. Da heißt Fehler = funktioniert nicht.


    Bei Exchange macht man sich einige Gedanken, bevor man implementiert oder gar Geld ausgibt.


    Zum Beispiel überlegt man sich vorher, welche Namen in das Zertifikat müssen. Du hast mobile Geräte, die wollen auch per Autodiscover angebunden werden -> und schon brauchst Du mindestens zwei Namen im Zertifikat.


    Dann probier weiter und melde Dich, wenn das nächste Problem kommt. ;)

    Grüße aus Berlin schickt Robert

  • Hi,


    hmm das ist ein Wildcard-Certificat, und egal von welchem Browser ich komme, er sagt: Das Certificat ist gut.


    Egal ob autodiscover.domain.tld oder exchange.domain.tld.


    Wenn es auf dem iPhone einen Fehler gibt, wird er mir nicht angezeigt.


    Beim anlegen gabs nicht 1 x den Hinweis das dort ein z.B. falsches Certificat hinterliegt.


    Grüße

  • Ah, ok. Ein Wildcard ist dann natürlich auch gut geeignet.


    Dann hast Du ja auch die benötigten Namen.


    Vermutlich lag es dann an fehlerhaft konfigurierten Activesync Urls. Die URLs von OAB/EWS/EAS und dem SCP müssen angepasst werden, auf den Namen, der im Cert steht.


    Und natürlich muss intern und extern DNS auf den Exchange zeigen (sog. Split DNS).

    Grüße aus Berlin schickt Robert

  • Hi,


    ah jo das mit dem Split-DNS hab ich schon gelesen / gehört.


    Ich hoffte ich kann das umgehen ;) Zur Zeit ist hier noch eine Fritzbox als DNS unterwegs .. auch in der Domain.


    Aber das werd ich dann mal ändern ;)


    Ich werde berichten ;)


    Grüße


    *Edit*


    Hm .. aber sekunde .. wenn die Fritzbox / der DNS das Problem ist: Warum konnte dann das Iphone sich syncen?!


    Das war auch per Wlan an der FB angebunden.


    Nichts destro trotz werde ich den DNS auf den DC legen, aber ich würds halt gerne verstehen :D


    Kann es ggf. folgendes sein:


    email: xxx@domain.tld
    webserver: domain.tld -> 123.123.123.123
    exchange: excahnge.domain.tld -> 312.312.312.312


    Aber das sollte doch auch kein Problem darstellen?! Im DNS-eintrag von der Domain hab ich den srv-eintrag _discover._tcp_.domain.tld auf discover.domain.tld gemacht und per cname einen eintrag von discover.domain.tld auf exchange.domain.tld.


    Grüße )

  • Nein, Split DNS willst Du nicht umgehen. Das macht Dir die Arbeit deutlich einfacher, weil Du dann intern und extern den gleichen Namen benutzen kannst.


    Und das mit der Fritzbox ist ganz blöd und muss schnellstens geändert werden! In Deinem Netzwerk ist der DC der DNS und kein anderer. Du musst in der Lage sein, AD-spezifische Einträge aufzulisten (das könnte auch ein Fehler sein, warum sich Outlook nicht verbinden will) und das geht nicht, wenn Du die FB benutzt.


    Du kannst vom DC DNS gerne auf die Fritzbox weiterleiten (ohne Einstellung macht der DC DNS rekursion und lässt gegen die Root-DNS-Server auf), aber mehr auch nicht.

    Grüße aus Berlin schickt Robert