Problem öffentlicher Ordner

  • Hallo ,
    entschuldigunglaublich falls es dieses Thema schonmal gab.
    Und zwar hab ich folgendes Problem. Ich wollte von einem SBS2011 die öffentlichen Ordner auf den neuen Exchange 2016 migrieren und habe über die exchange powershell ein neues Postfach für öffentlicher Ordner angelegt. Allerdings schlug die Synchronisation der Migrations Datei fehl und ich möchte nun gerne die öffentlichen Ordner wie pst. Datei einbinden. Allerdings kann ich keine Öffentlichen Ordner erstellen, da es anscheinend kein aktives Postfach gibt.
    Falls ich das per powershell Befehl angelegte Postfach für die öffentlicheneue Ordner löschen möchte, kann ich danach ohne den HoldForMigration Befehl kein neues anlegen, da anscheinend noch eine Migration läuft, obwohl dies nicht der Fall ist.



    Danke für eure Hilfe

  • Nur weil die Synch fehlschlägt nimmt man doch nicht pst Dateien. Man korrigiert die Fehler und führt die Synch zu ende.
    Ansonsten mußt du deine Mailbox wieder löschen und dann kannst auch neu anfangen. Ist nur wenig sinnvoll in meinen AUgen.


    Bye
    Norbert

  • Die Synchronistation schlägt immer mit folgendem Fehler fehl:


    Fehler: MigrationMRSPermanentException: Fehler: Eigenschaftenausdruck "Kontakte von Gemeinde" ist ungültig. Gültige Werte: Zeichenfolgen, die aus den Buchstaben A bis Z ?(Groß- und Kleinbuchstaben)?, Zahlen von 0 bis 9, !, #, $, %, &, ?', *, +, -, /, =, ?, ^, _, `, {, |, } oder ~ bestehen. In einem Alias kann mindestens ein Punkt eingebettet....


    Allerdings habe ich in der CSV Datei die Leerzeichen bereits entfernt. Oder liegt der Fehler hier woanders begraben?



    Habe auch bereits das Postfach für öffentliche Ordner gelöscht, welches mit dem HoldForMigration Befehl erstellt wurde, allerdings kann ich ohne diesen Befehl kein neues mehr in der EAC erstellen. Muss ich dazu noch etwas löschen?


    Dankeschön

  • Mußt du wohl mal die ganzen Aliasnamen bereinigen, da sich in denen erkennbar nicht gültige Zeichen befinden. "Kontakte von Gemeinde" beinhaltet Leerzeichen, und die sind nicht erlaubt. Du sollst die nicht in der CSV bereinigen, sondern im Exchange 2010.

  • Dies habe ich bereits getan, habe alle Leerzeichen durch _ ersetzt, allerdings immer noch der gleiche Fehler. Wie es aus sieht, werden die Namen nicht aktualisiert übernommen, da der gleiche Fehler wie oben nochmals angezeigt wird. Muss man hier für irgendetwas neustarten? oder gibt es eine andere Möglichkeit diesen HoldForMigration Modus zu beenden?

  • Die CSV sieht mittlerweie so aus. Genau die gleichen Namen sind im Exchange in der Öffentlichen Ordner Toolbox eingestellt. Funktioniert aber leider immer noch nicht. Hast du noch eine Idee?


    "FolderName","FolderSize"
    "\IPM_SUBTREE","0"
    "\IPM_SUBTREE\Archivierte_E-Mails","0"
    "\IPM_SUBTREE\Internet_Newsgroups","0"
    "\IPM_SUBTREE\Kontakte_von_Gemeinde","19248"
    "\IPM_SUBTREE\Raum-Fahrzeugplanung","7348635"
    "\NON_IPM_SUBTREE","0"
    "\NON_IPM_SUBTREE\EFORMS REGISTRY","0"



    Danke dir vielmals.

  • Die habe ich mit dem PS Befehl: .\PublicFolderToMailboxMapGenerator.ps1 21474836480 .\FolderToSizeMap.csv FolderToMailBoxMap.csv
    neu erstellen lassen.

  • Hi,


    du hast die (Anzeige-)Namen der Öff.Ordner geändert? Das bringt nichts und ist überflüssig.


    Du musst den Alias (mailnickname) ändern.


    Mailaktivierte Öff.Ordner mit Sonderzeichen im Alias findest du am schnellsten so:


    Get-MailPublicFolder | Where-Object {$_.Alias -match "\W"}


    Ändern des Alias in der Öffentlichen Ordner Veraltungskonsole (Ordner - Eigenschaften - Exchange-Allgemein -> Alias)


    (wäre auch mit Powershell möglich, Set-MailPublicFolder ... -Alias "blabla", aber bei zwei-drei Ordnern kommst du wohl besser mit der GUI)

    Mfg, exocheck